Jump to content
XtremeIdiots
coolmd

Anyone own AMD 5700 or 5700XT?

Recommended Posts

I just purchased the gigabyte 5700xt.

What a mistake.

I have not managed to get it to run without alot of various issues from BSOD, random crashes in games or simply browsing.

It appears many people are having similar issues and I tried many things to get it to wrk properly to no avail.

the only single thing that half worked was to use Wattman to undervolt the card but even then issues arose.

After coming from my trusty GTX 980 without a single problem ever I have decided to return the card to Amazon and have ordered the MSI 2070 super, £100 more but back to nvidia for me.

Just wonderd if anyone else has got this card and any problems that may have been encountered?

Share this post


Link to post
Share on other sites

All the reviews on this card say it rocks!!

If you are blue screening it is a hardware problem. It's obvious the card is broken. RMA it, take it back and get an aftermarket one.

The 5800's are going to be coming out in a couple of months.

Share this post


Link to post
Share on other sites

its doesnt blue screen.....just blackscreen straight into pc reboot....no warning...triple fans so its not thermal.

the many reviews by professionals dont mention problems but many many forums with problems and many more problems than I experienced.

When the PC reboots simply says Wattman has encountered problem and settings has been set to default.

If undervolted does work ok might get a few hours without problems but cant rely on it.

Shame i so wanted it to be good.

Many are saying its driver issues and new driver not out for a while.

Did manage through undervolting to get a Heaven Engine bench mark which was about  double my old faithful GTX 980.

ran BFV with ultra settings on 2560 x 1440 at about 80 fps on average.

So ran well but still with issues and dare not alter any radeon settings except for the undervolt being left on.

 

Share this post


Link to post
Share on other sites

Did you follow proper installation protocol ?   Remove old video drivers first, remove old card, install new card and then new drivers ?  May try uninstalling current driver and reinstall them ?  You overclocking the card or your motherboard ?  Could be a bad card too.  Could always send it back for a new one.  

Share this post


Link to post
Share on other sites

Oops sorry just saw you exchanged it.   I just put together a pc and used a 2080 in it and have been pleased with the card.    I too was thinking about a Radeon card and saw there were issues.  I got my crap at Microcenter and the salesman there said they have a alot of Radeon cards returned, because of stability issues.    

Share this post


Link to post
Share on other sites

AMD Wattman is a fucking joke. I've had problems with that damn thing on with "new" drivers for years with about 1/2 of the drivers AMD releases. I'm currently running the Minimal driver install without Radeon Settings and none of the other crap. And I'm using MSI Afterburner to slightly overclock and control the fans. 

 

Download this and run it to clean all of the junk left behind from previous driver installs.

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

And use This AMD driver for Win 10 64. Never EVER use the "Optional" driver. Your better off using a slightly older driver when it comes to AMD. Let it stew for a couple of months.

https://drivers.amd.com/drivers/win10-64bit-radeon-software-adrenalin-2019-edition-19.9.2-sep23.exe

 

Better yet use a driver that IRL people have tested and reported to be good from here. This is a slightly older driver but is said to work fine with the 5700 and 5700XT.

https://www.guru3d.com/files-details/amd-radeon-adrenalin-edition-19-9-1-driver-download.html

Share this post


Link to post
Share on other sites

16 hours ago, MikeB said:

Did you follow proper installation protocol ?   Remove old video drivers first, remove old card, install new card and then new drivers ?  May try uninstalling current driver and reinstall them ?  You overclocking the card or your motherboard ?  Could be a bad card too.  Could always send it back for a new one.  

Yes used DDU to remove in safemode etc....new drivers after card installed...all to no avail..there are far too many others outthere with numerous problems

 

Share this post


Link to post
Share on other sites

OMG it dont want me to change my graphics card....ordered new MSI 2070 super on Monday on Amazon prime...promised yesterday...nothing....contacted customer support..very sorry very sorry etc etc.....promised for today........still sitting in local depot..30 mles from me..contact them again....once again sorry sorry etc. We will make sure it comes today.. Of course you will......

wouldnt  mind too much but this card came with codes from free COD MW released tommorrow but will only work if card is installed...lol

Share this post


Link to post
Share on other sites

Yey me.. Hassled Amazon worked within an 1.5 hours card arrived....plugged it in downloaded drivers and HEY HO AND AWAY YOU GO.....no bios issues nothing to do except turn everything to ULTRA and boom it worked.

Did the same two benchmarks that i had done with 5700XT and the 2070 super did better in both benchmarks...I guess it should as it was £100 more.....

So never AMD again...I will stay with Nvidia.....just waiting for the codes now from Amazon for the COD mw....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...